Home Ask a Librarian Site Search

Need a Plug-in?

Many web pages need to have plug-ins installed before the page will display properly. The following plug-in programs are installed on the library computers. Use the links provided to download the plug-ins to your computer.

The library installs and uses the latest version unless otherwise noted.

Plug-in/Program

  1. Adobe Flash Player
  2. Adobe Shockwave Player
  3. Adobe Acrobat Reader
    1. Need for Blackwell e-books
      1. Installs normally into IExplorer
      2. Workaround required for FireFox 3
  4. EndNote Web (free user account required)
  5. Java

IDAHO STATE UNIVERSITY

921 South 8th Avenue
Pocatello, Idaho, 83209